Degraded service on https://help.mobileiron.com
Incident Report for Ivanti Cloud
Resolved
This incident has been resolved. All emails received during the outage have been added to cases or had cases created for them. If you believe that an email did not go through or would like to check on the status of a case please go to help.mobileiron.com to verify or update the case.
Posted Jul 12, 2018 - 16:29 UTC
Identified
We are facing issues with MobileIron Support Portal because of which some customers & partners are not able to create new/update tickets via support portal.

We are aware of the issue and working with the vendor to resolve it at the earliest.
Please call us via support line for any assistance.
Posted Jul 12, 2018 - 10:25 UTC